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[bookmark: _Toc367828504][bookmark: _Toc435443594][bookmark: _Toc436856701]Sistema Integrado de Segurança e Gestão de Energia
[bookmark: _Toc367828534]
O Sistema Integrado de Segurança e Gestão de Energia (SISGE) foi desenvolvido com o intuito de estudar quais as vantagens da utilização de um sistema deste tipo. Foi dada mais relevância à parte do sistema relacionada com monitorização de energia, por ser aquela em que existem menos estudos desenvolvidos por parte do VITA.IPT. 
O sistema desenvolvido é capaz de medir os consumos com uma precisão aceitável, nomeadamente o valor da tensão e da corrente, a potência ativa, o fator de potência e a energia consumida. A partir do valor da energia são apresentados os custos diários, semanais, mensais e anuais tendo em conta o serviço de energia contratado pelo consumidor.
Em termos de segurança, um sensor de deteção de presença foi incorporado no sistema, sendo este capaz de detetar a presença humana que origina a ativação de alarmes.
Tendo em conta desenvolvimentos futuros deste sistema, foram simulados alguns cenários de produção de energia e deteção de falhas de segurança.
O sistema apresentado é composto por uma unidade central de controlo e duas unidades periféricas (Figura 1). 
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[bookmark: _Ref435268949][bookmark: _Toc435443649][bookmark: _Toc435473007]Protótipo SISGE desenvolvido.

A informação vinda das unidades periféricas é guardada numa base de dados que é consultada pela aplicação SISGE. Esta é de acesso web e permite a visualização do consumo em tempo quase real, assim como o estado de sensores lógicos. A página principal da aplicação SISGE está representada na Figura 2.
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[bookmark: _Ref435290796][bookmark: _Toc435443650][bookmark: _Toc435473008]Página inicial da aplicação SISGE

[bookmark: _Toc435443603][bookmark: _GoBack]Diagrama do SISGE
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[bookmark: _Ref435365537][bookmark: _Toc435443653][bookmark: _Toc435473011]  Diagrama geral descritivo dos dispositivos utilizados.
[bookmark: _Toc436856702]Unidade Central – Raspberry Pi 2

[bookmark: _Toc436856703]Sistema Operativo
O sistema operativo é instalado diretamente no cartão microSD, a instalação é feita ligando o cartão microSD a um computador, sendo necessário efetuar os seguintes passo:
1. Descarregar uma imagem com o sistema operativo, disponível em: https://www.raspberrypi.org/downloads/raspbian/


2. Descompactar a imagem de dentro do ficheiro Zip.
3. Descarregar o software SD Formater em:https://www.sdcard.org/downloads/formatter_4/eula_windows/index.html



4. Descompactar e executar o software SD Formater.
5. Formatar o cartão microSD com o SD Formater.
6. Descarregar o software Win32 Disk Imager rem:http://sourceforge.net/projects/win32diskimager/


7. Instalar e executar o programa Win32 Disk Imager.
8. Abrir o Win32 Disk Imager, selecionar o ficheiro de imagem anteriormente descompactado e selecionar a unidade correspondente ao cartão microSD. Clicar no botão Write para dar início ao processo de escrita no disco. Quando este processo terminar basta inserir o catão no Raspberry Pi e ligar o mesmo.

A ligação SSH ao Raspberry Pi pode ser efetuada com o software Putty, efetuando uma ligação SSH ao endereço raspberrypi na porta 22.

[bookmark: _Toc435443613][bookmark: _Toc436856704]MQTT
Para instalar o servidor de MQTT Mosquitto no Raspberry Pi 2 devem ser executados através de uma ligação SSH os seguintes comandos:
wget http://repo.mosquitto.org/debian/mosquitto-repo.gpg.key
sudo apt-key add mosquitto-repo.gpg.key
cd /etc/apt/sources.list.d/
sudo wget http://repo.mosquitto.org/debian/mosquitto-wheezy.list
sudo apt-get update && sudo apt-get install mosquitto

Este conjunto de comandos adicionam a chave de verificação de veracidade e o reportório Mosquitto à lista de fontes de pacotes de instalação. De seguida é instalado o broker Mosquitto. Por padrão a porta do servidor é a 1883, esta manteve-se inalterada.
Para testar o correto funcionamento do broker foi efetuado um teste de subscrição e publicação para um tópico através da linha de comandos. Numa linha de comandos foi subscrito o tópico “sensors/temperature” com nível QoS igual a 1 ao utilizar o comando mosquitto_sub: 
mosquitto_sub -t sensors/temperature -q 1

Numa segunda linha de comando foi enviada uma mensagem através do comando mosquitto_pub, com o valor “32” para o canal “sensors/temperature” e com nível QoS igual a 1: 
mosquitto_pub -t sensors/temperature -m 32 -q 1

Resultando na receção por parte do subscritor de uma mensagem com o valor “32”.
Devido ao Router Ethernet restringir o acesso à rede a partir de fontes externas, optou-se por não configurar nenhum método de segurança adicional no broker. No entanto, este dispõe do comando mosquitto_passwd que permite a gestão de utilizadores e palavras-passe para autentificação dos clientes do servidor.

[bookmark: _Toc436856705]Instalação node RED
Para instalar o Node-Red no Raspberry Pi devem ser executados os seguintes comandos através de uma ligação SSH:
curl -sL https://deb.nodesource.com/setup_0.12 | sudo bash -
sudo apt-get install -y build-essential python-dev python-rpi.gpio nodejs
sudo npm install -g --unsafe-perm  node-red
sudo npm install -g node-red-node-mysql


Este conjunto de comandos descarrega e instala a aplicação Node-Red, assim como as suas dependências. Para iniciar o Node-Red o seguinte comando foi executado:
node-red-pi --max-old-space-size=128

O acesso à pagina web do Node-Red é feito através do endereço local http://raspberrypi:1880/.
	Para instalar o nó que permite a ligação a bases de dados MySQL o seguinte código deve ser executado:
	npm install node-red-node-mysql

Depois disto o Node Red deve ser reiniciado através do comando:
sudo /etc/init.d/nodered restart


[bookmark: _Toc436856706]Importação código Node RED
Para importar os fluxos desenvolvidos, depois de instalado o Node Red e o nó MySQL, deverão ser seguidos os seguintes passos:
1. Aceder à página do Node Red e clicar no menu de opções existente no topo direito da página, e aceder à opção Import > Clipboard.
2. Copiar o conteúdo do fluxo que se deseja importar e colar na janela que surgiu na página do Node Red. Confirmar clicando em Ok.

[bookmark: _Toc435443605]O código fornecido encontra-se comentado, e está disponível no DVD anexado a este documento. 

[bookmark: _Toc436856707]Base de dados - MySQL
Para instalar a base de dados MySQL deve ser executado os seguintes passos:
sudo apt-get install mysql-server --fix-missing
sudo apt-get install mysql-client


Durante o processo de instalação da base de dados será requisistado uma palavra-pass para o utilizador root da base de dados. 
Os seguintes passos devem ser seguidos para proceder à criação da base de dados:
mysql -uroot -hlocalhost –p – ligar ao servidor de base de dados
CREATE DATABASE SISGE; --criar base de dados
CREATE USER dbuser@'localhost' IDENTIFIED BY 'sisge';
GRANT ALL PRIVILEGES ON SISGE.* TO 'dbuser'@'localhost';
FLUSH PRIVILEGES;
exit
mysql -udbuser -hlocalhost SISGE –p
SET GLOBAL event_scheduler = ON; --ativa a execução de eventos



Para executar a gestão da base de dados, ou seja, criação e manutenção das tabelas, vistas, triggers e eventos, aconselha-se o uso do software Dbeaver. 
Após criar uma ligação à base de dados utilizando o endereço de IP do Raspberry Pi, utilizar dbuser e palavra-passe sisge, os scripts SQL disponíveis no DVD fornecido juntamente com este documento devem ser executados. Os scripts encontram-se comentados.
Os serviços e preços da energia devem são inseridos na tabela PRICES. As definição do serviço, ciclo horário e potência contratada é feita na tabela OPTIONS.

[bookmark: _Toc436856708]Interface gráfica - Dashing
A aplicação Dashing executa sobre um serviço Ruby (ruby-dev) que já se encontrava instalado no Raspberry Pi. A instalação do Dashing no Raspberry Pi foi feita ao ser executado o seguinte comando:
sudo gem install dashing

Para importar a aplicação desenvolvida, a pasta sisge fornecida juntamente com este documento deve ser copiada para a pasta de rede disponível em:
\\raspberrypi\pi\

ou diretamente através de ftp para a pasta
/home/pi/

A aplicação é iniciada ao ser executado o seguinte comando:
dashing start -d

A programação da interface é feita em tês locais:
· ficheiro home.erb que contem todo o código html que invoca os widgets de todas as páginas. É neste ficheiro que se decidem quais e como são dispostos os widgets (data-row/data-col), assim como a sua dimensão (data-sizex/data-sizey).
· Scripts em linguagem Ruby. Estes scripts executam serviços ao iniciar da aplicação ou em rotinas programadas. Estão localizados dentro da página jobs.
· Configurações dos widgtes que contém três ficheiros:
· Script coffeescript que executa invocações REST e define valores dos widgets ,entre outras possibilidades;
· Ficheiro html que contém a estrutura do widget;
· Ficheiro scss que contém a programação javascript de configuração dos estilos do widget. 
O envio de dados da interface para o Node-Red é feito através de um serviço REST local da aplicação, isto porque por razões de segurança da aplicação a chamada de serviços deste tipo não pode ser feita diretamente pelo WebBrowser do utilizador. Os serviços criados para este efeito são iniciados pelo script nred.rb contido na pasta jobs. O ficheiro com as funções executadas sempre que um serviço é chamado, encontram-se na pasta lib no ficheiro NRApp.rb. 
O código desenvolvido encontra-se comentado e está no DVD entregue juntamente com este documento.


[bookmark: _Toc436856709]Unidades periféricas – Arduino e NodeMCU

[bookmark: _Toc436856710]Preparação IDE desenvolvimento
Depois de efetuado o download do IDE Arduino da página e de modo a configurar o ambiente para poder compilar o código desenvolvido para o Arduino Mega e NodeMCU, os seguintes passos devem ser seguidos:
1. Abrir o IDE Arduino e ir a File > Preferences e adicionar ao campo Additional Board Manager URLs o seguinte URL:http://arduino.esp8266.com/stable/package_esp8266com_index.json


2. Carregar Ok e abrir o meno Tools > Board: > Board Manager.
3. Procurar por “esp8266” e instalar a biblioteca. Aguardar que termine a instalação e de seguida reiniciar o IDE.
4. Instalar a biblioteca PubSubClient para utilização com o MQTT indo a Sketch > Include Library > Manage Libraries
5. Pesquisar a biblioteca PubSubClient selecionar e instalar a mesma.

[bookmark: _Toc436856711]Programação dos microcontroladores

Para programar os microcontroladores os seguintes passos devem ser efetuados:
1. Abrir o IDE Arduino, no menu Tools > Board: Selecionar a placa de desenvolvimento que se deseja programar (Arduino ou ESP8266) e selecionar a porta de comunicação série correspondente ao mesmo em Tools > Port.
2. Abrir o código correspondente à placa e carregar no botão Upload e esperar que a compilação e envio terminem.

O código utilizado está disponível no DVD anexado a este documento. O mesmo encontra-se comentado.

[bookmark: _Toc435443611][bookmark: _Toc436856712]Meios de comunicação
Para configurar o Shield Ethernet no Arduino foi utilizada a biblioteca Ethernet.h, disponível no IDE Arduino e de livre utilização. Esta biblioteca é responsável pelo controlo do circuito integrado W51000, em que foram utilizadas as seguintes funções:
byte mac[]    = {  0xDE, 0xEE, 0xBA, 0xFE, 0xFE, 0xED }; 
IPAddress ip(192, 168, 1, 11);
EthernetClient ethClient;
Ethernet.begin(mac, ip);    

Em que, “mac” representa o endereço físico que se deseja atribuir ao dispositivo a registar na rede Ethernet. A função “IPAddress” define o endereço de IP que mais tarde será atribuído ao dispositivo. Um novo cliente de Ethernet é criado através da função “EthernetClient”. Este cliente será chamado sempre que se queira enviar ou receber informação para a rede. O registo do dispositivo na rede é feito pela função “Ethernet”, que regista o endereço “mac” e o seu respetivo endereço de IP na rede.
A ligação de Wi-Fi integrada no microcontrolador ESP8266 permite a ligação direta do microcontrolador ao Router.
A biblioteca ESP8266WiFi.h foi utilizada para registar a placa NodeMCU na rede Wi-Fi. Foi utilizado o seguinte conjunto de funções presentes nesta biblioteca:
WiFiClient espClient;
WiFi.begin(ssid, password);
WiFi.status()

A função “WiFiClient” cria um novo cliente de Wi-Fi que será chamado sempre que se queira enviar ou receber informação para a rede. É utilizada a função “WiFi.begin()” para registar o dispositivo na rede identificada pelo seu SSID. Para verificar o estado da ligação é utilizada a função “WiFi.status()”.
A unidade central de controlo do sistema, o computador Raspberry Pi 2, liga-se à rede Ethernet através da porta RJ45 disponível no mesmo. A atribuição de um endereço de IP é automática e gerida pelo Router.
A biblioteca PubSubClient.h foi utilizada para registar as placas Arduino e NodeMCU no servidor Mosquitto. As funções de publicação/subscrição de tópicos funcionam em conjunto com as funções das bibliotecas de ligação às redes Ethernet e Wi-Fi, é através dos seus clientes que as mensagens MQTT são enviadas. As seguintes funções da biblioteca PubSubClient.h foram utilizadas:
PubSubClient client(ethClient);
client.connect("Nome_Cliente")
client.subscribe("subscrever/tópico");
client.publish("publicar/tópico", mensagem);
client.setServer(server, 1883);
client.setCallback(callback);
client.connected()

Em que, a função “PubSubClient” cria um cliente MQTT através de uma ligação Ethernet ou Wi-Fi. A função “connect()” regista o cliente no broker. A informação sobre o endereço do broker é feita através da função “setServer()”. A verificação do estado da ligação ao broker é feita pela função connected().  A subscrição de tópicos é feita recorrendo à função “subscribe()”, enquanto a publicação de mensagens para tópicos é feita recorrendo à função “publish()”. Quando uma mensagem é enviada para um tópico subscrito por um destes clientes o método “callback” é chamado para que a mensagem possa ser recebida. Este método é definido no cliente local pela função “setCallback”. 
[bookmark: _Toc367828594]
[bookmark: _Toc436856713]Definição das constantes
A alteração das constantes ultilizadas para calculo dos valores da tensão, corrente, tempo de envido das leituras e estado dos atuadores pode ser feito através de um WebBrowser ao invocar o seguinte link:http://raspberrypi:1880/services/rest/sendOptions?_nome_da_opcao_=_valor_

em que _nome_da_opcao_ é o nome da constante que queremos alterar o valor e _valor_ é o valor para o qual se pretentede alterar.
	Estas constantes podem ser definidas diretamente na base de dados.
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